Resolved
The incident affecting file uploads across the platform has been fully resolved. File uploads are now functioning normally for all users, and no further issues are expected. We’ve completed monitoring and confirmed stability.
Monitoring
We’ve identified the cause of the file upload failures and deployed a fix. The issue was related to how file upload requests were being handled in the browser, which caused some uploads to fail before reaching storage. This has now been resolved, and file uploads should be working normally again across the platform.
We’ll continue to monitor closely to ensure stability. If you continue to experience any issues uploading documents, please contact Support.
Investigating
We’re currently investigating an issue that’s preventing file uploads from completing successfully on the Lawhive platform.
You may see an error when uploading documents to cases, and files may fail to upload across all file types. This impacts both lawyers and clients.
Our engineering team is actively working to identify the cause and restore normal service as quickly as possible.
We’ll share another update as soon as we have more information.